The green lights go out during charging / there are no green lights when I plug in my Embr Wave.

In some cases, the green charging lights may go off (or fail to come on) even though your Embr Wave is charging properly! This may be due to a communication error between the indicator lights and USB port you are using. We're currently working on a fix for the issue, to be released in a future firmware update.
 
In the meantime, here's what you can try:
  1. Plug your cable into a different port (e.g., a different USB wall plug or a different USB port on your computer) and see if the green lights come on/stay on for a full charge.
  2. After 1.5 hours, check your Wave's battery status in the app.

If your battery status is High and the green charging lights turn to solid green, congrats! This means the USB port you've just tried is able to communicate with your device's indicator lights, and everything is working as it should.

If your battery status is High but the green charging lights didn't stay on or come on for the full 1.5 hours, that means your battery is charging properly but the indicator lights aren't communicating with the USB port correctly. This will be fixed in a future firmware update. In the meantime, you can continue to use your Embr Wave and charge it by leaving it plugged in for 1.5-2 hours. (If the lack of indicator lights is a problem and you don't want to wait for a firmware update, please contact us!)

If your battery status is Low, you may have a faulty battery. Please contact us for a replacement.

 
Can’t find your answer in our support center? Contact us directly.